Running Median:
The median of a set of integers is the midpoint value of the data set for which an equal number of integers are less than and greater than the value. To find the median, you must first sort your set of integers in non-decreasing order, then:
- If your set contains an odd number of elements, the median is the middle element of the sorted sample. In the sorted set , is the median.
- If your set contains an even number of elements, the median is the average of the two middle elements of the sorted sample. In the sorted set , is the median.
Given an input stream of integers, you must perform the following task for each integer:
- Add the integer to a running list of integers.
- Find the median of the updated list (i.e., for the first element through the element).
- Print the list's updated median on a new line. The printed value must be a double-precision number scaled to decimal place (i.e., format).
Input Format
The first line contains a single integer, , denoting the number of integers in the data stream.
Each line of the subsequent lines contains an integer, , to be added to your list.
Each line of the subsequent lines contains an integer, , to be added to your list.
Constraints
Output Format
After each new integer is added to the list, print the list's updated median on a new line as a single double-precision number scaled to decimal place (i.e., format).
Sample Input
6
12
4
5
3
8
7
Sample Output
12.0
8.0
5.0
4.5
5.0
6.0
Explanation
There are integers, so we must print the new median on a new line as each integer is added to the list:
Code:
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;
public class Solution {
private static PriorityQueue<Integer> maxheap = new PriorityQueue<>(Collections.reverseOrder());//max heap
private static PriorityQueue<Integer> minheap = new PriorityQueue<>();//min heap
public static void main(String args[] ) throws Exception {
/* Enter your code here. Read input from STDIN. Print output to STDOUT */
Scanner sc = new Scanner (System.in);
int n = sc.nextInt();
int []arr = new int [n];
for (int i=0;i<n;i++){
arr[i]=sc.nextInt();
}
medianTracker(arr);
}
private static void medianTracker(int [] arr){
for (int j=0;j<arr.length;j++){
addNumber(arr[j]);
System.out.println(getMedian());
}
}
private static void addNumber(int n){
if (maxheap.size()==0){
maxheap.add(n);
} else if (maxheap.size()==minheap.size()){
if (n<minheap.peek()){
maxheap.add(n);
}else{
minheap.add(n);
maxheap.add(minheap.poll());
}
}else if(maxheap.size()>minheap.size()){
if(n>maxheap.peek()){
minheap.add(n);
}else{
maxheap.add(n);
minheap.add(maxheap.poll());
}
}
}
private static double getMedian() {
if (maxheap.isEmpty()) {
return 0;
} else if (maxheap.size() == minheap.size()) {
return (maxheap.peek() + minheap.peek()) / 2.0;
} else { // maxHeap must have more elements than minHeap
return maxheap.peek();
}
}
}
Comments
Post a Comment